Command “python setup.py egg_info” failed with error code 1 : Cryptography

Hello all, as always, I came up with a new issue I faced while installing erpnext with an easy install script. It was not an expected error. Even I have installed erpnext several times, didn’t get this issue with ubuntu 18.04 until now. However, just need to remind you, using 16.04 won’t be a solution for the future anymore.

Anyways, I’m not sure whether these steps will work or not. But it’s better to teach you to try them. Sometimes, it can save you your valuable time.

1. Try using sudo as stated in the above answer.

sudo pip3 install --upgrade pip

2. Try to do a fresh reinstall of pip

apt-get remove python3-pip

pip3 install -U pip

I hope, it should work. However, let me know if you got any issues. I always try to help people, because I know how hard to start with errors as a beginner or intermediate one. Good luck!