Hello, I got another issue when I was installing a package on lumen using the composer. This is the error I got, “Composer requires runs out of memory. PHP Fatal error: The allowed memory size of 1610612736 bytes exhausted”. However, I tried different techniques but didn’t work. Most of the people have mentioned in some forums to change php.ini. However, I didn’t want to change it and found out the following solution.

However, If you are experiencing this issue, type following lines one after one, on your terminal to change the memory limit, and install other necessary packages.

set COMPOSER_MEMORY_LIMIT=-1
composer require hwi/oauth-bundle php-http/guzzle6-adapter php-http/httplug-bundle

I hope, your problem solved. If you got any issues, please let us know in the comment section below. We will help you as soon as possible.

Write A Comment